Bienvenido a la web de la Oficina del Software Libre y Conocimiento Abierto de la Universidad de Cádiz

GNU/Linux

Asuntos relacionados con el sistema operativo GNU/Linux

Comparativa de la OCU sobre sistemas operativos

En el n.º 325 de abril de 2008 de su revista «Compra Maestra», la O.C.U. (Organización de Consumidores y Usuarios) hace una comparativa de 3 sistemas operativos de escritorio que se pueden utilizar en ordenadores personales o portátiles hoy en día: Windows Vista, Mac OS/X 10.5 Leopard y Ubuntu 7.10 Gutsy Gibbon.

Las conclusiones son que ninguno es mucho mejor que otro. Las calificaciones, resumidas, son:

Se buscan profesores para cursos de Guadalinex

Una consultora de la bahía de Cádiz está buscando docentes para impartir cursos de formación sobre Guadalinex para diferentes colectivos, en horario de mañana.

Si estás interesado, por favor, contacta con nosotros por correo electrónico: <osl ARROBA uca.es>.

DECENT VIA GRAPHICS DRIVERS FOR LINUX

Con ese nombre se ha abierto una petición on-line para que VIA publique unos drivers mejores para sus chipsets gráficos en GNU/Linux. Más información

Java y los 64 bits: soluciones

Siguiendo con el artículo anterior, veremos las posibilidades que tenemos para soslayar la falta del pluguín de Java para AMD64/EM64T (x86_64). Hay que decir que tanto el problema como las soluciones son aplicables a cualquier distribución de Linux x86_64.

 

  • Apañárselas sin el pluguín de Java. Esto no es realmente una solución, claro.
  • Para los usuarios de KDE: usar Konqueror para ver páginas con applets Java. Konqueror no usa el pluguín, sino que llama directamente al intérprete de Java y empotra el programa en su ventana.
  • Instalar un pluguín de Java de 64 bits... pero ¿no dije que no hay? Bueno, en realidad hay uno, Blackdown Java Linux, pero corresponde a la versión 1.4 de Java, por lo que muchas páginas que requieren Java no van a funcionar.
  •  Quitar el navegador (Firefox) de 64 bits e instalar el de 32, junto con la JVM de 32 y el pluguín de Java, que sólo es de 32.
  • Dejar el navegador (Firefox) de 64 bits e instalar manualmente aparte el de 32, junto con la JVM de 32 y el pluguín de Java. Esto es algo complicado y explicaré más abajo cómo se hace.
  • Instalar otro navegador de 32 bits, junto con la JVM de 32 y el pluguín de Java. Por ejemplo, y por mencionar otro navegador libre, Seamonkey, el sucesor de Mozilla Navigator.

 

Java y los 64 bits

Hace poco escribí sobre OpenSUSE 10.3 y dije que en una máquina con arquitectura de 64 bits (x86_64) instalaba el Firefox de 64 bits, y curiosamente funcionaban los complementos o conectores o plugins de Flash, Adobe Reader y otros propietarios que solo están para 32 bits.

El milagro viene de la mano del paquete nspluginwrapper, que es capaz de hacer funcionar dichos plugins de 32 bits en un Firefox de 64.

El problema es la máquina virtual de Java. Existe el JRE (entorno de ejecución de Java) de Sun para 32 y 64 bits, pero, no sé por qué, el plugin sólo existe para 32 bits, y además no es compatible con los plugins de Netscape 4, por lo que nspluginwrapper no puede hacerlo funcionar.

Distribuir contenido